slow responses from DNS upstream provider
Incident Report for iwantmyname
Resolved
All systems are up and running again. Thank you for your patience!
Posted Oct 18, 2016 - 09:12 UTC
Identified
We currently see slow responses and timeouts from our DNS upstream provider which may affect dashboard load times and DNS updates. We are in contact with the upstream provider and hope to have the problem resolved soon.
Posted Oct 18, 2016 - 04:27 UTC