iwantmyname website unavailable
Incident Report for iwantmyname
Resolved
All systems are up and running again. Thanks for your patience!
Posted Sep 29, 2014 - 08:23 UTC
Identified
Our hosting provider is undergoing a major maintenance outage. We'll be back as soon as we can.
Posted Sep 29, 2014 - 02:39 UTC
Investigating
We have been alerted of an issue with the iwantmyname website and dashboard.
Posted Sep 29, 2014 - 02:29 UTC