Information not loading
Incident Report for iwantmyname
Resolved
All back up and running.
Posted Mar 24, 2017 - 07:08 UTC
Investigating
We are currently investigating DNS, nameservers and WHOIS information not showing for our users - your information and records are preserved they are just not presently loading.
Posted Mar 24, 2017 - 06:47 UTC