iwantmyname dashboard loading slowly
Incident Report for iwantmyname
Resolved
Dashboard pages are fully operational again. Sorry for the brief service interruption!
Posted Dec 16, 2014 - 19:26 UTC
Investigating
We have been notified about a performance issue with the iwantmyname dashboard and are currently looking into it.
Posted Dec 16, 2014 - 19:13 UTC