Outage at one of our technical partners
Incident Report for iwantmyname
Resolved
All systems are operational again. Thanks for your patience!
Posted May 25, 2016 - 09:05 UTC
Identified
One of our technical partners currently has an outage that is affecting the domain search as well as nameserver updates. We're monitoring the status and expect systems to be back to normal shortly.
Posted May 25, 2016 - 08:26 UTC