Connection Troubles
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted Oct 23, 2014 - 08:43 UTC
Monitoring
The connection issues have been fixed, and we're keeping an eye on the situation.
Posted Oct 23, 2014 - 07:34 UTC
Investigating
We're aware of connection issues to an upstream provider. We'll let you know when we know more.
Posted Oct 23, 2014 - 06:41 UTC