DNS manager unavailable
Incident Report for iwantmyname
Resolved
The DNS manager is operational again. Thanks for your patience!
Posted Apr 07, 2015 - 20:50 UTC
Identified
The DNS manager is not currently displaying records or allowing changes. We are investigating why, please bear with us!
Posted Apr 07, 2015 - 20:28 UTC