DNS dashboard and record propagation currently degraded
Incident Report for iwantmyname
Resolved
Alls clear
Posted May 19, 2017 - 21:47 UTC
Investigating
There is currently an issue affecting adding to/updating customers' DNS dashboards, and the related websites and email operating. We're looking into it. Please refrain from making DNS changes for the time being.
Posted May 19, 2017 - 20:56 UTC