Credit card update outage
Incident Report for iwantmyname
Resolved
This incident has been resolved -- thanks for your patience!
Posted Nov 12, 2020 - 02:50 UTC
Identified
We are currently experiencing an issue processing credit card updates. The issue has been identified and a fix is being implemented. We'll let you know when we're back up and running.
Posted Nov 12, 2020 - 02:25 UTC
This incident affected: Dashboard and Order processing.