Upstream provider outage
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted Feb 06, 2020 - 08:23 UTC
Identified
Once of our upstream providers is currently experiencing problems, which is preventing search, order processing, and possibly some admin-dashboard functions. We'll take this notice down once they're back up and running.
Posted Feb 06, 2020 - 07:25 UTC
This incident affected: Domain search, Dashboard, and Order processing.