Search is down
Incident Report for iwantmyname
Resolved
Search is back up and running. Thanks for your patience!
Posted Apr 28, 2021 - 05:59 UTC
Investigating
Our domain search is currently down, but the dev team is on it. We'll post an update once we've identified and fixed the problem.
Posted Apr 28, 2021 - 04:55 UTC
This incident affected: Domain search.