Some slow pages and errors with order processing
Incident Report for iwantmyname
Resolved
Order processing, and dashboard pages should be back to normal now. Thank you for your patience.
Posted May 20, 2017 - 07:12 UTC
Monitoring
Our order processing system has had problems, which we've identified and fixed. This means some pages may be slow while our system catches up on the backlog. Thank you for bearing with us while this happens.
Posted May 20, 2017 - 06:45 UTC