Email Service Disruption

Incident Report for iwantmyname

Resolved

This incident has now been resolved. Thanks for your patience!
Posted Mar 25, 2025 - 22:11 UTC

Investigating

We are currently experiencing a service disruption affecting our email delivery system. This issue impacts all email communications, including two-factor authentication (2FA) emails, which will prevent successful login to the portal for users using 2FA emails.
Our technical team is actively working to resolve this issue. We apologize for any inconvenience this may cause.

Thank you for your patience and understanding.
Posted Mar 25, 2025 - 18:00 UTC
This incident affected: Website and Order processing.