Site outage - Routing is temporarily broken
Incident Report for iwantmyname
Resolved
All back to normal, thanks for your patience.
Posted 4 months ago. Feb 01, 2019 - 11:24 UTC
Investigating
We are currently fixing our site routing.
Posted 4 months ago. Feb 01, 2019 - 11:04 UTC
This incident affected: Website, Domain search, Dashboard, DNS hosting, Order processing, and Blog.