Degraded performance

Incident Report for iwantmyname

Resolved

This incident has been resolved. Thank you for your patience!
Posted Mar 16, 2022 - 08:31 UTC

Investigating

We are currently experiencing slow loading times and 503 errors on our site. Our devs are looking into this, and we'll update as soon as we know more.
Posted Mar 15, 2022 - 22:07 UTC
This incident affected: Website, Domain search, Dashboard, DNS hosting, and Order processing.