Website user dashboard is running slow

Incident Report for iwantmyname

Resolved

This incident has been resolved.
Posted Feb 16, 2021 - 16:35 UTC

Investigating

We are currently investigating this issue.
Posted Feb 16, 2021 - 11:11 UTC
This incident affected: Website, Dashboard, DNS hosting, and Order processing.