Issue with transfers into iwantmyname
Incident Report for iwantmyname
Resolved
This incident has now been resolved. If you have any questions, please feel free to reach out!
Posted Mar 05, 2022 - 21:11 UTC
Investigating
We've had reports of a bug affecting domains being transferred to iwantmyname. We're investigating this and will let you know when we have an update.
Posted Mar 02, 2022 - 03:41 UTC
This incident affected: Order processing.