Cyclone Gabrielle Affecting Customer Care
Incident Report for iwantmyname
Resolved
The team is now back to normal operating levels. We'd like to thank our customers for their patience during this extreme weather event which thankfully had a minimal business impact.
Posted Feb 20, 2023 - 03:34 UTC
Identified
While all online services (DNS and other infrastructure-related products and services) remain unaffected by Cyclone Gabrielle, our Customer Care teams are currently affected by this severe weather event.

We have made arrangements to ensure Customer Care requests are being actioned. However, our response times are currently affected.

Our key focus for the next 24-48 hours is that of our staff in New Zealand who are affected by cyclone Gabrielle, and we thank all of our customers for your understanding at this time. Our global Customer Care teams will be monitoring queues across ticketing and chats to capture any urgent issues to assist those cases first. Still, we expect our standard SLA to adjust above 24hrs for the next day or two.

We will post an update when one is available and send our thoughts to all those affected in New Zealand.

iwantmyname & CentralNic
Posted Feb 13, 2023 - 22:54 UTC
This incident affected: Customer Care.