Degraded performance

Incident Report for iwantmyname

Resolved

This incident has been resolved.
Posted Oct 14, 2022 - 07:57 UTC

Update

We are continuing to investigate this issue.
Posted Oct 14, 2022 - 06:08 UTC

Investigating

We're currently experiencing problems with our search and dashboard due to an outage at our upstream provider. We'll let you know as soon as we're back up and running again. So sorry for the inconvenience!
Posted Oct 14, 2022 - 06:08 UTC
This incident affected: Website, Domain search, Dashboard, DNS hosting, Order processing, and Blog.