Domain search and domains in dashboard are not showing
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted Oct 29, 2021 - 07:31 UTC
Update
We are continuing to investigate this issue.
Posted Oct 29, 2021 - 07:30 UTC
Update
Our domain search tool is now working, we are continuing to investigate the user dashboard.
Posted Oct 29, 2021 - 06:26 UTC
Investigating
We are currently investigating problems with our domain search and existing domains not displaying in your dashboard.
Posted Oct 29, 2021 - 05:48 UTC
This incident affected: Website, Domain search, Dashboard, DNS hosting, and Order processing.