Support form not working
Incident Report for iwantmyname
Resolved
This incident has been resolved and cases sent during the outage will be answered shortly. Thanks for your patience!
Posted Aug 03, 2020 - 04:57 UTC
Investigating
We are currently experiencing issues receiving requests via our support form. While we investigate and fix, please contact us via email help@support.iwantmyname.com
Posted Aug 03, 2020 - 04:36 UTC
This incident affected: Website.