Maintenance window: 2022-01-10 10:00 UTC to 2022-01-14 10:00 UTC
Incident Report for iwantmyname
Resolved
This maintenance window is now complete. Should you experience any further issues please contact our support teams via the usual channels.
Posted Jan 14, 2022 - 10:43 UTC
Identified
From 2022-01-10 10:00 UTC to 2022-01-12 10:00 UTC we will be in a maintenance window to complete infrastructure upgrades. Services remain active, though there may some intermittency while DNS changes take effect.
Posted Jan 10, 2022 - 03:54 UTC
This incident affected: Website, Domain search, Dashboard, DNS hosting, and Order processing.