SSL Errors On Site
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted Mar 22, 2022 - 15:30 UTC
Monitoring
The issue has been located and a fix implemented. We'll monitor for now to make sure all is well.
Posted Mar 22, 2022 - 12:29 UTC
Investigating
We are currently investigating SSL errors on the site as a result of a recent deployment. Update due shortly.
Posted Mar 22, 2022 - 12:24 UTC
This incident affected: Website, Domain search, Dashboard, DNS hosting, Order processing, and Blog.