Problem with our payment system.
Incident Report for iwantmyname
Resolved
Payment system is up and running again. All system operational.
Posted 11 months ago. Sep 14, 2018 - 00:21 UTC
Investigating
We are currently experiencing problems with our payment system. Our team is looking into the issue and we'll update as soon as we know more.
Posted 11 months ago. Sep 13, 2018 - 23:16 UTC
This incident affected: Order processing.