Limited customer support during the holidays
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted Jan 04, 2022 - 02:33 UTC
Monitoring
Please be aware that our customer success team will be taking a well-deserved break during the holiday season, so support availability will be limited over this period.

Here is the schedule, all times are in NZDT: https://time.is/New_Zealand
24 Dec - open until midday
25 Dec - CLOSED
26 Dec - CLOSED
27 Dec - CLOSED
28 Dec - open, limited support
29 Dec - open as usual
30 Dec - open as usual
31 Dec - open until midday
1 Jan - CLOSED
2 Jan - CLOSED
3 Jan - CLOSED
4 Jan - open, limited support
5 Jan - back to normal

Take care!
Posted Dec 23, 2021 - 01:00 UTC