Upcoming Deployment - 13:30 UTC
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted Apr 13, 2022 - 14:55 UTC
Monitoring
Deployment Complete - We're keeping an eye on things for now.
Posted Apr 13, 2022 - 14:03 UTC
Identified
During the upcoming deployment site availability may be briefly affected ( 13:30 UTC - 14:00 UTC ) - Any customers experiencing issues should subscribe to updates via the status page for complete service restoration
Posted Apr 13, 2022 - 12:55 UTC
This incident affected: Website, Domain search, Dashboard, DNS hosting, Order processing, and Blog.