Upstream technical partner outage impacting domain search and other functionality
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 12, 2019 - 23:40 UTC
Monitoring
Our upstream provider seems to be back and we monitor the situation now
Posted 3 months ago. Apr 12, 2019 - 22:55 UTC
Identified
An outage at our upstream technical partner is impacting our search and other functionality. We're very sorry for this inconvenience and will be live again once our partner have resolved the issue.
Posted 3 months ago. Apr 12, 2019 - 22:07 UTC
This incident affected: Domain search, Dashboard, and Order processing.