Slow domain search results
Incident Report for iwantmyname
Resolved
Systems are up and running again. Thanks for bearing with us, happy holidays!
Posted Dec 27, 2019 - 08:57 UTC
Monitoring
We're working on a fix for domain search results being slower than usual. You may see single pages in your iwmn account to load a bit slower as well. Sorry for the inconvenience.
Posted Dec 27, 2019 - 08:17 UTC
This incident affected: Domain search and Dashboard.