Server maintenance
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted 4 months ago. Jan 31, 2019 - 11:05 UTC
Monitoring
We're doing some server maintenance at the moment. This shouldn't have any affects for customers, and should be done in 2 hours. We'll remove this notice when the maintenance is finished.
Posted 4 months ago. Jan 31, 2019 - 09:38 UTC