Scheduled Maintenance
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted 10 months ago. Oct 18, 2018 - 09:17 UTC
Investigating
We're working on some internal improvements for our servers at the moment. We don't expect these changes to affect any customers services, and they should be finished in an hour.
Posted 10 months ago. Oct 18, 2018 - 07:55 UTC