Website user dashboard is running slow

Incident Report for iwantmyname

Resolved

This incident has been resolved. Thanks for your patience!
Posted Jun 01, 2021 - 05:12 UTC

Investigating

Our user dashboard is currently running slow. Our devs are investigating the issue, and we'll let you know once we have a resolution.
Posted Jun 01, 2021 - 04:14 UTC
This incident affected: Dashboard and DNS hosting.