Problems with an upstream service
Incident Report for iwantmyname
Resolved
we're back - the fox is out of the hen-house
Posted Feb 29, 2020 - 12:08 UTC
Update
We are continuing to investigate this issue.
Posted Feb 29, 2020 - 09:43 UTC
Investigating
One of our upstream partners is experiencing problems and it's preventing some dashboard functions and our search from working. We're leasing with our upstream provider to try and address this.
Posted Feb 29, 2020 - 09:43 UTC
This incident affected: Domain search and Dashboard.