Domains and domain search maintenance
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted Oct 24, 2023 - 09:34 UTC
Investigating
We're currently conducting some maintenance and our domains and domain search system will be down for around 30 mins.
Posted Oct 24, 2023 - 08:30 UTC
This incident affected: Website, Domain search, Dashboard, and DNS hosting.