Registrations and renewals are not being processed for accounts with new/updated credit cards
Incident Report for iwantmyname
Resolved
All systems are fully operational now and all transactions are processing normally. Thank you for your patience.
Posted about 1 year ago. Mar 01, 2018 - 22:01 UTC
Identified
We have identified an issue with a payment processing partner, which affects credit card authentication. These authentications can't be completed at present, preventing transactions (registration or renewal) on accounts with a new or updated credit card that has not been used for transactions with us before.

All such transactions remain pending, and we will ensure they're processed when our partner resolves the issue.
Posted about 1 year ago. Mar 01, 2018 - 17:38 UTC