Search is down
Incident Report for iwantmyname
Resolved
Search is now back up and running. Thanks for your patience!
Posted Sep 04, 2019 - 02:09 UTC
Investigating
Our domain search is currently down, but the dev team is on it. We'll post an update once we've identified and fixed the problem.
Posted Sep 04, 2019 - 01:42 UTC
This incident affected: Domain search.