Domain search not return prices
Incident Report for iwantmyname
Resolved
We've squashed the search bug. You can now resume your quest to find the perfect domain.
Posted Aug 30, 2021 - 17:59 UTC
Update
We are continuing to investigate this issue.
Posted Aug 30, 2021 - 17:58 UTC
Investigating
We are currently investigating problems with our domain search and why prices are not being returned
Posted Aug 30, 2021 - 17:54 UTC
This incident affected: Domain search.