Maintenance at our upstream partner
Incident Report for iwantmyname
Resolved
Maintenance is now complete; thank you for your patience!
Posted 10 months ago. Oct 21, 2018 - 04:22 UTC
Monitoring
Our upstream partner is doing planned maintenance from 00:00 to 04:00 UTC. During this time, search, registrations, and domain update functions in the dashboard will be affected. Thank you for your patience.
Posted 10 months ago. Oct 21, 2018 - 00:02 UTC
This incident affected: Website, Domain search, Dashboard, and Order processing.