Dashboard outage
Incident Report for iwantmyname
Resolved
This incident has been resolved. Thanks for your patience!
Posted Jun 16, 2022 - 05:34 UTC
Investigating
We are currently experiencing system issues - please bear with us while our developers identify and fix!
Posted Jun 16, 2022 - 05:12 UTC
This incident affected: Website, Domain search, Dashboard, and Order processing.