Domain search is down
Incident Report for iwantmyname
Resolved
Our domain search is back up ... the mole has been thoroughly whacked.
Posted over 1 year ago. Mar 08, 2018 - 20:58 UTC
Identified
Currently domain search is not working. This is preventing new registrations. Searches will show that they are taking a while, but will not update. The developers are working on the issue. All other website functions are working normally.
Posted over 1 year ago. Mar 08, 2018 - 18:11 UTC