Slow domain search results
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted 12 months ago. Sep 05, 2018 - 08:10 UTC
Investigating
We're experiencing slow domain search results at the moment, please bear with us while we fix this issue.
Posted 12 months ago. Sep 05, 2018 - 08:07 UTC
This incident affected: Domain search.