Degraded performance

Incident Report for iwantmyname

Resolved

This incident has been resolved. Thanks for your patience!
Posted Jul 06, 2022 - 05:22 UTC

Identified

We've identified the cause of the issue and are working on a fix.
Posted Jul 05, 2022 - 02:06 UTC

Investigating

We are currently experiencing issues loading domain information. We're investigating this now and will let you know once a fix is in place.
Posted Jul 05, 2022 - 01:12 UTC
This incident affected: Dashboard.