Upstream partner API outage - domain registations currently not working
Incident Report for iwantmyname
Resolved
Domain registration working now.
Posted 4 months ago. Jul 11, 2017 - 21:26 UTC
Monitoring
Domain registration working now.
Posted 4 months ago. Jul 11, 2017 - 20:42 UTC
Investigating
We are currently investigating this issue.
Posted 4 months ago. Jul 11, 2017 - 20:34 UTC