Degraded performance
Incident Report for iwantmyname
Resolved
Incident resolved
Posted Apr 25, 2024 - 18:10 UTC
Identified
We're currently experiencing problems with our search and dashboard due to an outage at our upstream provider. We'll let you know as soon as we're back up and running again. So sorry for the inconvenience!
Posted Apr 25, 2024 - 17:37 UTC
This incident affected: Website, Domain search, Dashboard, DNS hosting, and Order processing.