Problems with new transactions
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted over 1 year ago. Jan 11, 2018 - 09:52 UTC
Update
We've managed to temporarily resolve the problem. All users should be able to buy domains again, and we're working on a more permanent fix for the issue.
Posted over 1 year ago. Jan 11, 2018 - 07:03 UTC
Monitoring
We're having connection problems with one of our service providers, which means that some customers will have trouble buying new domains at the moment. Domain renewal should work fine. We're monitoring the problem and hope to have it resolved shortly.
Posted over 1 year ago. Jan 11, 2018 - 06:16 UTC