Search is currently not returning results
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted 9 months ago. Nov 16, 2018 - 12:52 UTC
Investigating
We are currently investigating this issue.
Posted 9 months ago. Nov 16, 2018 - 11:17 UTC
This incident affected: Domain search.