Down ATM, but working on it.
Incident Report for iwantmyname
Resolved
All systems are up and running again. Thanks for your patience!
Posted about 1 year ago. Aug 14, 2018 - 13:59 UTC
Identified
Due to unexpected turbulences on some of our servers, we're currently experiencing a downtime. All hands are already on deck to bring back iwantmyname as soon as possible. Your domains are not affected.
Posted about 1 year ago. Aug 14, 2018 - 13:17 UTC
This incident affected: Website, Domain search, Dashboard, and Order processing.