Limited customer support over Easter
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted Apr 18, 2022 - 21:42 UTC
Identified
Please be aware that Support availability will be limited over Easter weekend. Tickets can continue to be submitted via https://iwantmyname.com/support and will be actioned as soon as possible. Take care!
Posted Apr 14, 2022 - 04:49 UTC