Our help system is not working at the moment
Incident Report for iwantmyname
Resolved
This incident is now resolved and we've responded to all outstanding support queries. Thanks for your patience!
Posted May 27, 2019 - 02:26 UTC
Identified
We're having problems with our help system, used to respond to customer requests. If you have sent us a request for support recently it may take us an unusually long time to respond to you, so please bear with us while we work through this issue.

All other parts of the site are operating fine.
Posted May 26, 2019 - 12:22 UTC