Upstream maintenance
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted Mar 21, 2022 - 10:56 UTC
Update
Our upstream provider has confirmed that live service will now not be affected
Posted Mar 21, 2022 - 10:56 UTC
Investigating
Our upstream provider is under maintenance. During this time, domain search, order processing, and domain management in the dashboard may be affected. We expect to be up and running by 1200 UTC: https://time.is/UTC
Posted Mar 21, 2022 - 07:35 UTC
This incident affected: Domain search, Dashboard, and Order processing.