Upstream maintenance
Incident Report for iwantmyname
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 20:07 UTC
Identified
Our upstream provider is under maintenance from 0700 UTC 2022-06-21. Domain search, order processing, and dashboard domain management will be affected. We should be back to normal by 1500 UTC: https://time.is/UTC
Posted Jun 21, 2022 - 03:26 UTC
This incident affected: Website, Domain search, Dashboard, and Order processing.